Third party e57 embedded panoramas having wrong orientation after upload

Incident Report for NavVis

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 15:36 UTC

Monitoring

We are happy to let you know that the issue causing incorrect panorama orientation in third-party E57 uploads has been resolved.

To apply the fix, please re-upload your E57 file. Your panoramas should then appear correctly positioned.

If you continue to experience any issues after re-uploading, please don't hesitate to reach out and we will be happy to assist.

We apologize for the inconvenience this may have caused and thank you for your patience.
Posted Apr 24, 2026 - 13:10 UTC

Investigating

We are currently investigating an issue affecting customers who upload third-party E57 files containing panoramas. Panoramas in these files may appear incorrectly positioned, displaying with random rotations rather than their intended orientation.

Our team is actively looking into the root cause. We will provide an update as soon as we have more information.
Posted Apr 23, 2026 - 15:38 UTC
This incident affected: Platform (NavVis IVION).